Forecast partly unavailable
Incident Report for injixo
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 16:55 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2020 - 16:54 UTC
Investigating
We are currently investigating this issue.
Posted Nov 18, 2020 - 16:51 UTC
This incident affected: Forecast.