Missing menu item ShiftCenter
Incident Report for injixo
Postmortem

We accidentally rolled out the ActiveX free version which favors Schedules and disabled ShiftCenter.
Due to configured automatic updates this release has been rolled out nightly for some of our the customer.
We detected this 8:04 CEST today and rolled back to the correct version.
Unfortunately this has forced an unexpected down time for affected customer.

To avoid that in future we will:

  • Extended feature rollout to stop if not yet marked as intended
  • Improve our automatic rollbacks for accidentally published changes (if they occur)

We applogize the service disruption and will hardening our failure management.

Posted Oct 23, 2020 - 07:41 UTC

Resolved
This incident has been resolved.
Posted Oct 23, 2020 - 07:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 23, 2020 - 07:18 UTC
Update
We found the root cause and a fix will be applied soon. Unfortunately this will lead to a small downtime if customer is affected.
Posted Oct 23, 2020 - 06:40 UTC
Identified
The issue has been identified and a fix is currently being implemented.
Posted Oct 23, 2020 - 06:17 UTC
Investigating
We are currently experiencing a service disruption.

Some users may be experiencing trouble when using shift center.

Our development team is working to identify the root cause and implement a solution.

We will send an additional update as soon as we found the root cause.
Posted Oct 23, 2020 - 06:04 UTC
This incident affected: WFM.